sabato 22 marzo 2008

[Excel]Funzioni condizionate: CONTA.SE()

Diversi nostri lettori mostrano interesse per le funzioni di Excel e per i primi passi con l'applicativo.
In questi giorni di vacanza dalla scuola posso dedicarmi alla presentazione di qualche interessante funzione. Naturalmente, per lettori e pargoli (alunni)! :-)

Parliamo dunque di

funzioni condizionate.
Tali funzioni operano e forniscono un risultato solo dopo aver verificato che gli argomenti soddisfano a determinate condizioni richieste dall'utente.
Una di queste funzioni è CONTA.SE()
Un problema:
In un campeggio estivo per ragazzi da 9 a 16 anni si sono costituite 3 squadre, denominate A, B e C.
Della squadra A fanno parte i ragazzi da 9 a 11 anni,
della B quelli da 12 a 14 anni e
della C i ragazzi da 15 a 16 anni.
Dalla tabella in Excel che associa ogni ragazzo a una squadra vogliamo ottenere il numero di componenti di ciascuna squadra.
In seguito vedremo anche come ottenere la somma dei componenti di due o tre squadre a scelta.
In un foglio di lavoro prepariamo una tabella:
Risolviamo il problema di contare quanti sono i componenti di ciascuna squadra:
In cella E1 digitiamo Squadra e nelle celle sottostanti, uno per cella, il nome delle squadre: A, B, C.
In F1 digitiamo Componenti
Per ottenere in F2 il numero di componenti la squadra A, si dovrebbe contare il numero di A presenti nella colonna Squadra della nostra tabella; a questo pensa Excel con la funzione CONTA.SE()
Vediamo la sintassi della funzione.
CONTA.SE() conta il numero di celle in un intervallo che soddisfano i criteri specificati.

Sintassi
CONTA.SE(intervallo;criteri)

Intervallo è l'intervallo di celle dove bisogna cercare gli elementi da contare.
Criteri
sono i criteri, la condizione espressa sotto forma di valore numerico, riferimento di cella, relazione o testo, in base alla quale il programma sceglie quali elementi dell'intervallo contare, cioè quali celle verranno contate.
Ad esempio, criteri può essere espresso come 32, A1, "32", ">32", "mele".

Tornando al nostro problema, in cella F2 immettiamo dunque la formula:
=CONTA.SE($C$2:$C$21;"A")
Il nostro intervallo è $C$2:$C$21 (riferimenti assoluti, per riferirci al medesimo intervallo, variando il criterio)
Il criterio, la condizione, è la lettera A, che indica la squadra (osserva: A è un testo, quindi va messo tra virgolette).
Per il calcolo dei componenti le squadre B e C, dobbiamo ripetere in F3 e F4 la stessa formula cambiando solo l'argomento del criterio.
Il risultato ottenuto sarà questo:

Ma... non sappiamo noi della "praticità" di Excel? :-)
Per calcolare il numero di componenti delle tre squadre abbiamo dovuto cambiare l'argomento criterio nella formula!
Più rapidamente (ma è così che va utilizzato Excel!) saremmo giunti allo stesso risultato con la formula immessa in questo modo:
=CONTA.SE($C$2:$C$21;E2)
l'argomento criterio è il contenuto della cella E2, cioè la lettera A (E2, rif. relativo, il criterio cambia copiando la formula lungo la colonna).
Si copia semplicemente dunque la formula nelle due celle sottostanti, F3 e F4 e il gioco è fatto!
in cella F3 E2 diventerà E3, e in F4, E4.

Ma non è finita!
Si è detto che l'argomento criteri può essere anche una relazione. Possiamo perciò utilizzare gli operatori di confronto.
La funzione CONTA.SE() ci permette allora qualche altra indagine (ricordo che CONTA.SE() è una delle funzioni appartenenti alla categoria Statistiche): conoscere per es. quanti sono i ragazzi del campeggio di età maggiore di 11 anni.
In una cella immettiamo la formula:
=CONTA.SE($B$2:$B$21;">11")
L'intervallo è quello della colonna B della tabella, contenente le età, il criterio maggiore di 11, va messo tra virgolette.
Il risultato ottenuto è 13.
Ancora un esempio:
vogliamo conoscere il numero di ragazzi di età maggiore o uguale a 14.
La formula in questo caso è:
=CONTA.SE($B$2:$B$21;">=14")
Otteniamo il risultato 9.
Si può scaricare il file d'esempio CONTA.SE()

Voglio segnalare infine che il problema del calcolo dei componenti le tre squadre si potrebbe risolvere anche evitando l'utilizzo della colonna C della tabella. NON con la funzione CONTA.SE() però! Si dovrebbe utilizzare il calcolo matriciale che noi conosciamo un po'. Potremmo esemplificare in uno dei prossimi post!:-)
AGGIORNAMENTO
In riferimento alla nota qui sopra: non volendo ricorrere alle formule matriciali per calcolare il numero dei componenti delle squadre considerando esclusivamente le fasce d'età, si può utilizzare un "doppio" CONTA.SE. [Le funzioni CONTA.SE e SOMMA.SE non consentono di specificare criteri multipli come ad esempio un intervallo di valori compreso tra un valore minimo e un valore massimo]
La soluzione, insieme ad altri esempi di SOMMA.SE e CONTA.SE con 2 criteri, si può vedere sul file aggiornato Conta.Se()_Somma.se()_2.xls
A disposizione per eventuali chiarimenti.

Articoli correlati per categorie



Stampa il post

7 commenti:

  1. Carissima Giovanna, auguro a te e ai tuoi ragazzi una serena Pasqua.
    Spero che almeno voi abbiate un po' di sole, qui piove e tira vento.
    Saluti dal Friuli
    Maria Pia

    RispondiElimina
  2. Oggi non commento... Faccio solo tanti auguri di buona Pasqua a tutti...
    Un abbraccio!

    RispondiElimina
  3. Ancora auguri a Maria Pia e ancora auguri a Angelo!
    grazie da parte di tutti noi!

    RispondiElimina
  4. maestra Elisa23 marzo 2008 10:15

    Ciao Giovanna: Auguri pe runa felice Pasqua a te alla tua famiglia e ai ragazzi! Ho cercato di lasciare un commento nel blo di maestra Giovanna ma lo respinge!
    non so come farle i complimenti per il tangram magico!
    Un abbraccio
    elisa

    RispondiElimina
  5. Ciao Elisa.
    ti ringrazio tanto da parte di tutti!
    Ricambio con affetto!
    Sul blog di Maria Giovanna a me respinge solo l'URL, quindi non lo metto. Il messaggio lo accetta.
    le riferirò comunque...grazie.
    un abbraccio a te.
    g.

    RispondiElimina
  6. si può cercare una cella e si può chiedere di contare i valori maggiori di un dato numero: è possibile combinare in qualche modo le due cose e chiedere di contare il numero di valori maggiori del contenuto di una cella? Se sì, come?

    RispondiElimina
  7. Si può, così:
    =CONTA.SE(B1:B20;">"&A1)

    RispondiElimina

I vostri commenti sono graditissimi, l'interazione è molto utile!
Non ci piace però comunicare con "anonimi". Vi preghiamo di firmare i vostri messaggi.
Come fare:
Cliccare su Nome/URL.
Inserire il vostro nickname nel campo "nome".
Lasciate vuoto il campo URL se non avete un blog/sito.

Grazie!